istockphoto.com server is very slow!

Displaying 1 to 12 of 12 matches.
microgen
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsExclusive
Posted Tue Dec 25, 2012 3:47AM

Hi,


I know this issue has been raised before, but since nothing changed and it's getting worse only, I think we need to do something. Or at least to bring tech team awareness to red alert level.


For me it usually takes from 6 to 12 seconds to receive response from istockphoto.com. It's the RESPONSE TIME that I'm talking about, not the actual download or upload speed, those are good. So when you click on any istock page, several seconds pass in: waiting for www.istockphoto.com, before page starts loading. Loading itself is fast after initial waiting period.


I think that this is related only to istockphoto.com while all other URLs that often load with pages work well. (criteo.com,dotomi.com, gigya.com, liveperson.net, doubleclick.net, istockimg.com, microad.jp, google-analytics....)  




I think issue started in September. Got better in November but it lasted only for a week or so. This directly conicides with drops in sales to many contributors, I believe also to sales in general. 




Now this is the result from Vertain's free server speed test, performed through superfast connection from US: 


Speed test results:
s
    URL:   http://istockphoto.com
    s
    The test timed out, as the page did not complete loading in 15 sec.

     You should definitely be concerned about your server's speed!



In last few months, result was usually around 10 seconds, but today went over 15. It's good to be around 3. 


I'm somewhat experienced with similar issues and could add few ideas for tech team to try, but let's see what other people say and how this discussion develops. There are many skilled IT technicians and managers amongst contributors, I hope to hear from some. 


Let's try to be constructive


Thanks
kelvinjay
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsMember is a contributor and has less than 250 Illustration downloadsExclusive
Posted Tue Dec 25, 2012 5:05AM
I am in Spain, on an less than average broadband connection and everything seems to be zipping along here at its usual speed. Pages typically taking 1 to 3 seconds, depending on how much info, photos etc are on them.

I tried that speed test myself and it too said it timed out after 15 seconds, which is odd because, as I said, iSock seems to be loading all pages fast and working well. So I'm not really sure what conclusions you can draw from that site's measurements.
microgen
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsExclusive
Posted Tue Dec 25, 2012 6:36AM

Thanks for the input.


This response time changes, its not always so slow, but I think it should be checked seriously. I wrote this post because I noticed it myself and later found few clients complaining in forums about this same thing. 


There are also other server response time checking services, some operating from different locations in the world. There are several types of tests and data is not consistent 


Any IT professionals that know more about this?
wolv
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto Videographer
Posted Tue Dec 25, 2012 10:11AM
Vertain is not a very good site to test speed. I checked 3 different url's and they each took between 14-15 seconds. I then tested the url's in my browser and they each took approx 1 second.
microgen
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsExclusive
Posted Tue Dec 25, 2012 11:13AM

Thanks Wolv,


Don't know what to think really. I started this topic because site is slow for me and I checked it from few locations and different machines. Some clients reported this same thing in forums. It's ok if you buy one photo, you don't notice it really, but if you need a set, it's time consuming and becomes annoying.


This Vertain may not be the best choice, but it used to be good before. Constantly gives reasonable response times for other photo agency websites, while we keep getting warnings.


Hope to hear more opinions here. I'll look further for professional help on this, either with some IT guys or with shrinks


Cheers
wolv
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto Videographer
Posted Tue Dec 25, 2012 11:51AM
I find this site pretty good for test speed.
microgen
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsExclusive
Posted Tue Dec 25, 2012 12:49PM

Looks good and brings reasonable results. But I think this test says about elements of the page and how long does it take for those to download. Eventual issue is about response time, or the time that is needed for server to respond to your request. If you are using Chrome, after you click to load another page, message: Waiting for www.istockphoto.com... should be appearing in lower left corner. And I think that lasts too long. Several seconds or so
sjlocke
Member is a Black Diamond contributor and has more than 200,000 Photo downloadsMember is a Gold contributor and has 5,000 - 12,499 Video downloadsMember is a Bronze contributor and has 125 - 1,249 Audio downloadsMember is a Silver contributor and has 2,500 - 9,999 Illustration downloadsExclusiveExclusive iStockphoto IllustratorExclusive iStockphoto Videographer
Posted Tue Dec 25, 2012 2:08PM
Speed is fine here.
Willowpix
Member is a Silver contributor and has 2,500 - 9,999 Photo downloadsExclusive
Posted Tue Dec 25, 2012 2:15PM
Speed is good here.
microgen
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsExclusive
Posted Tue Dec 25, 2012 2:23PM
ok, thanks
microgen
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsExclusive
Posted Wed Dec 26, 2012 2:45AM
I asked a pro to check it and he also reported that there are no response time problems. Unlike Vertain, some other free testing tools reported the same. I still have a problem, though not as bas as yesterday, 3-4 secs delay. So finally it must be either local issue caused by some of my plug-ins, set of bad circumstances or something else. My appologies. You may close the topic
kelvinjay
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsMember is a contributor and has less than 250 Illustration downloadsExclusive
Posted Wed Dec 26, 2012 2:58AM
Ok. Good luck with resolving your issue.

This thread has been locked.
Displaying 1 to 12 of 12 matches.
Not a member?Join