Add Photos to E+ Greasemonkey Script Stopped Working?

Displaying 1 to 18 of 18 matches.
wdstock
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a Bronze contributor and has 125 - 1,249 Audio downloadsExclusiveExclusive iStockphoto VideographerExclusive iStockphoto Audio Artist
Posted Fri Mar 1, 2013 6:25AM
The great script for adding E+ seems to have stopped working. Is it just me? I also noticed that the exclusive crown icon/E+ icon doesn't seem to appear on individual image pages anymore. Anyone else seeing this?


Thanks!

(Edited on 2013-03-01 07:15:36 by wdstock)
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Fri Mar 1, 2013 7:56AM
adding E+ seems to have stopped working


Ugh! Yes, it looks like things on the my_uploads and image details pages must've changed. I'll try and get a look at this soon.
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Mon Mar 4, 2013 11:31AM
I'm not clear about whether the changes to the istock pages are a temporary glitch or a permanent change, so I've made changes to the script so that it should work either way.

Anyone using the Chrome browser, I strongly recommend that you install the script from the Chrome store.
If you have the old version of the script installed, go to the Extensions screen and disable or remove the old iStock Add To E-Plus script.
Then install from the Chrome store, here.

If you're using FireFox or some other browser, or want to manually install into Chrome, you can get the script from:
http://www.theasis.co.uk/iStock/istock_eplus.user.js

As the old thread for this script is locked due to age, I'll post the details on how to use it in the post below this...

(Edited on 2013-03-04 11:37:28 by theasis)
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Mon Mar 4, 2013 11:32AM
I've written a GreaseMonkey script to make adding files to the E+ collection a little less painful.

If you install the script, you'll get a new big red button on photo pages for your non-E+ exclusive files:
eplus1

If you click the big red button and all goes well, your file gets moved to E+ and you get a pop-up message something like:
eplus2

Alternatively, you can work from the my uploads page also.
You'll see a new checkbox on the my uploads page:
eplus3

Click that and the Collection column will change from:
eplus4
to:
eplus5

Click on the red buttons to move any image to E+.
Click on the grey buttons to move any image out of E+ and back into the main collection.

Let me answer some questions you might ask:

Q: What's GreaseMonkey?
A: There are some good answers in Sean's thread over here.

Q: Is it safe?
A: Heck no! If you're risk-averse, you don't want to use this. It seems to work fine for me, but I've not tested very many ways of making it fail since any test will result in moving a file into the E+ collection for 6 months. There's a chance it will fail, delete your account, kick your dog, throw water on your cat, and send your gerbil to places a gerbil should never go. Use at your own risk. But I expect it'll work out fine.

Q: Will it work with Photo+?
A: I doubt it. I haven't made any effort to make it work with P+ because, as I'm exclusive, I have absolutely no way to test it. Sorry.
Edit to add: the code's right there! It's free to modify. If you're non-Exclusive and willing to test on your own files, go right ahead and change it to work for P+, or find someone who knows JavaScript to do it for you. There's nothing in my code that should take long for a competent programmer to figure out, and I can answer questions if some parts turn out to be trickier than I think. You have my permission to use it and change it.

Q: Can I remove files from E+ this way, also?
A: Yes! Big red buttons add photos to E+. Big grey buttons remove photos from E+ back to the main collection.

Q: What else?
A: There are a few things to be aware of:
- when you use the official istock E+ page, you get a "do you really want to do this? Your file will be locked for 6 months!" warning each time you try to add a file to E+. This script does not give you a warning. You are expected to be aware that files are locked into E+ for 6 months. If you click the big red button, the move to E+ just happens;
- the script isn't aware of whether or not a file is locked out of E+ (because you removed it from E+ recently). You will probably get the "Add to E+" button for these locked files. It probably won't get moved to E+ if you click the button. The sky probably won't fall in;
- iStock are probably going to improve the official E+ page and make this script redundant. Let's all hope so! Huzzah!

If you're using a GreaseMonkey-friendly browser and have GreaseMonkey installed (e.g. Chrome, or FireFox with the GreaseMonkey plugin) the you can install the script from:
http://www.theasis.co.uk/iStock/istock_eplus.user.js

Enjoy!

(Edited on 2013-03-04 11:36:34 by theasis)
wdstock
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a Bronze contributor and has 125 - 1,249 Audio downloadsExclusiveExclusive iStockphoto VideographerExclusive iStockphoto Audio Artist
Posted Mon Mar 4, 2013 12:37PM
Great, thanks! It seems to work for the my_uploads, but not on the individual image pages, is that as intended?
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Mon Mar 4, 2013 12:43PM
Posted By wdstock:
Great, thanks! It seems to work for the my_uploads, but not on the individual image pages, is that as intended?

It's working on the individual image pages for me (Chrome 25 on Win7 and Linux).
What browser are you using? Do you get any errors in the JavaScript console?
fotoVoyager
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 2,499 Flash downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveMember has had a File Of The WeekAwarded to fabulous photographers with more than 100,000 downloadsMember has won a contest
Posted Mon Mar 4, 2013 12:46PM
Thanks so much for maintaining this script - it's very useful!
wdstock
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a Bronze contributor and has 125 - 1,249 Audio downloadsExclusiveExclusive iStockphoto VideographerExclusive iStockphoto Audio Artist
Posted Mon Mar 4, 2013 1:36PM
Posted By theasis:

Posted By wdstock:
Great, thanks! It seems to work for the my_uploads, but not on the individual image pages, is that as intended?


It's working on the individual image pages for me (Chrome 25 on Win7 and Linux).
What browser are you using? Do you get any errors in the JavaScript console?

I'm using Firefox 19.0 on Win7x64. No errors as far as I know, just didn't have the "buttons" on the individual image pages.
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Mon Mar 4, 2013 1:55PM
Posted By wdstock:
I'm using Firefox 19.0 on Win7x64. No errors as far as I know, just didn't have the "buttons" on the individual image pages.


OK. I just installed FF19 and it worked fine. Check in the Add-ons Manager that it picked up the right version of my script:

eplus2

If so, do you have any other scripts installed? It might be worth temporarily disabling the others to see if that makes the E+ script start working. If it does, try switching the others on one at a time and refreshing your image page to see which script it's interacting badly with.

If none of that helps...um...we'll think of something else
Gannet77
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsExclusive
Posted Mon Mar 4, 2013 3:09PM
/
/
Posted By theasis:
...
If you're using FireFox or some other browser, or want to manually install into Chrome, you can get the script from:
http://www.theasis.co.uk/iStock/istock_eplus.user.js

...

The version for FireFox at the address above seems to still be version 1.8 ...
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Mon Mar 4, 2013 3:21PM
Posted By Gannet77:
The version for FireFox at the address above seems to still be version 1.8 ...

Interesting - it's definitely v2.0 there. I just downloaded and checked.
I wonder if there's a cacheing issue somewhere.

Anyway - I've also put a copy at http://www.theasis.co.uk/iStock/noReally-IMeanIt/istock_eplus-andsomerandomjunk.user.js

That definitely won't be cached

(Edited on 2013-03-04 15:21:54 by theasis)
Gannet77
Member is a Gold contributor and has 10,000 - 24,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsExclusive
Posted Mon Mar 4, 2013 3:54PM

^ Yep, that is version 2.0!  Seems to work fine, thanks!


As you say, must be a cacheing issue somewhere - I downloaded from the first address and it was definitely still the old one that I got.
fstop123
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsExclusiveExclusive iStockphoto VideographerRecognizing those who reach the 100,000 download mark
Posted Mon Mar 4, 2013 4:30PM
You are amazing.  Worked fine, first try.  Thank you.
wdstock
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a Bronze contributor and has 125 - 1,249 Audio downloadsExclusiveExclusive iStockphoto VideographerExclusive iStockphoto Audio Artist
Posted Mon Mar 4, 2013 8:44PM
Posted By Gannet77:

^ Yep, that is version 2.0!  Seems to work fine, thanks!


As you say, must be a cacheing issue somewhere - I downloaded from the first address and it was definitely still the old one that I got.


Yes that's it! I had the same problem, the first link said 1.8. The new link you created had 2.0.


An awesome tool!! Thanks again!
pidjoe
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsExclusiveMember has had a File Of The Week
Posted Tue Mar 5, 2013 12:01AM

Worked in one time, thank you.If I can do it,well; it's idiot-proof.  


 
26ISO
Member is a Silver contributor and has 2,500 - 9,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsExclusive
Posted Tue Mar 5, 2013 2:47AM

Posted By fstop123:
You are amazing.  Worked fine, first try.  Thank you.


I fully agree. Thank you so much
mammuth
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a contributor and has less than 250 Video downloadsMember is a contributor and has less than 250 Flash downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveMember has had a File Of The Week
Posted Mon Mar 18, 2013 11:30AM
There is a slight problem with the script, now the "Add to E+" button appears on vetta image pages too, I accidentaly clicked on it, and the script worked so I degraded one of my vettas to E+ Is there any way to hide the button from vetta pages?  I think they changed something in the source code of vetta images beacuse the button was hidden in the old times  
theasis
Member is a Diamond contributor and has 25,000 - 199,999 Photo downloadsMember is a Bronze contributor and has 250 - 1,249 Video downloadsMember is a contributor and has less than 125 Audio downloadsMember is a contributor and has less than 250 Illustration downloadsExclusiveExclusive iStockphoto VideographerSpecial Ops - Awarded to Administrators as a temporary badge to denote their dedication to large horrible jobs that pay little or nothing. Bearers are rewarded with great respect and public admiration.
Posted Mon Mar 18, 2013 3:13PM
Posted By mammuth:
There is a slight problem with the script, now the "Add to E+" button appears on vetta image pages too, I accidentaly clicked on it, and the script worked so I degraded one of my vettas to E+ :D Is there any way to hide the button from vetta pages?  I think they changed something in the source code of vetta images beacuse the button was hidden in the old times :) 

Oops!
Thanks for letting me know. I'll see to that ASAP. I'll assume that Agency files will have exactly the same problem (I can't test it as I don't have any agency files.)

I hope that file's hugely successful for you in E+, and thanks for taking the hit for all of us!
This thread has been locked.
Displaying 1 to 18 of 18 matches.
Not a member?Join